Google Translate no longer working | LWT: Basic questions, set up, troubleshooting, feedback | Forum

Google Translate no longer working | LWT: Basic questions, set up, troubleshooting, feedback | Forum

Benny
A A A

Please consider registering
guest

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Minimum search word length is 3 characters - maximum search word length is 84 characters

Topic RSS Related Topics
Google Translate no longer working
Topic Rating: 0 (0 votes) 
February 17, 2012
04:28
yenome

Member
Forum Posts: 24
$0
Member Since:
July 5, 2011
Offline
1
0

A few days ago, Google Translate (both put in as Dict1 and as GTranslate) stopped working in both my local and FI3M version of Learning with Texts. I assume this is because of a change in the way that Google Translate is handling post variables or something like that; anyone have any insight on how I can get it back up?

Speak: English, русский, español Read: Deutsch, Latina, Ænglisc Learn: suomi, runa shimi, فاریس
February 17, 2012
04:53
Lingo

moderator
Forum Posts: 664
$1745
Member Since:
June 25, 2011
Offline

I take the liberty of quoting from the developer's forum:

2012-02-13 12:48:25 PST

Please put an asterisk "*" in front of the Google Translate URI in your language setting(s), e.g. for French *http://translate.google.de/?ie=UTF-8'sl=fr'tl=en'text=### Then a new popup window will open (check any popup blocker if not). Google Translate seems to work then. If you keep the new window open all the time, the position and size of the popup window will be remembered and not changed.

[...]

I hope this workaround helps. And maybe google'll reenable this feature soon (it seems like they changed their policy twice in the last couple of days).

Speaks:  German English French Portuguese Russian Spanish       Collecting resources for: Mandarin Italian     Abandoned: Latin

February 20, 2012
00:24
LWT_Project

Member
Forum Posts: 85
$0
Member Since:
August 3, 2011
Offline
3
0

The above described problem doesn't anymore exist. Google Translate displays its results in a frame without problems. If this problem occurs again in the future, please follow the following advice:

Please put an asterisk "*" in front of the Google Translate URI in your language setting(s), e.g. for French *http://translate.google.de/?ie=UTF-8'sl=fr'tl=en'text=### Then a new popup window will open (check any popup blocker if not). Google Translate seems to work then. If you keep the new window open all the time, the position and size of the popup window will be remembered and not changed.

I DON'T POST HERE ANYMORE. -- If you have problems with Benny's version of LWT: Search or ask here. -- If you have problems with the Original version of LWT: Go to the LWT help forum. -- Thank you.
February 23, 2012
00:11
rcrichards
New Member
Forum Posts: 5
$0
Member Since:
November 23, 2011
Offline
4
0

I followed the solution outlined above; inserted a star "*" before both of the URI for the dictionary and google in the language setting on LWT.  However this did not resolve the issue. Any thoughts? 

February 23, 2012
15:36
Lingo

moderator
Forum Posts: 664
$1745
Member Since:
June 25, 2011
Offline
5
0

rcrichards said:

I followed the solution outlined above; inserted a star "*" before both of the URI for the dictionary and google in the language setting on LWT.  However this did not resolve the issue. Any thoughts? 

I tried to reproduce the error, but the asterisk seems to work as designed: if I click on "GTr", a new window containing the result of the lookup pops up. If you provide us with more details (and maybe screenshots) regarding your an exact description of the problem (do you see a popup window? If so, can you provide a screenshot?), your LWT settings, OS and Browser (popup blockers active?) etc, maybe someone can come up with a workaround.

Speaks:  German English French Portuguese Russian Spanish       Collecting resources for: Mandarin Italian     Abandoned: Latin

February 23, 2012
17:07
rcrichards
New Member
Forum Posts: 5
$0
Member Since:
November 23, 2011
Offline
6
0

Lingo,

 

I am using safari in windows 7 with default LWT settings, but the problem appears to be that pop-ups are blocked in the browser as a default (or were).  Google is officially off my Christmas card list for this stunt.

 

Rob

February 23, 2012
23:54
yenome

Member
Forum Posts: 24
$0
Member Since:
July 5, 2011
Offline
7
0

Command+Shift+K should toggle pop-up blocking on and off in Safari.

Speak: English, русский, español Read: Deutsch, Latina, Ænglisc Learn: suomi, runa shimi, فاریس
March 10, 2012
13:52
Lingo

moderator
Forum Posts: 664
$1745
Member Since:
June 25, 2011
Offline
8
0

This post does not offer a solution to the problem and if you do not consider yourself an computer geek, this post is probably not worth reading. Hopefully, this post can motivate some people to look further for other workarounds or start their own research/development...

 

If you look at the response (for instance, using http://web-sniffer.net/ ) to a typical Google translate URI, you'll notice "X-Frame-Options:SAMEORIGIN" (see here for an explanation; I suppose this might be related).

I wonder if the following quote can lead to something:

Quote from vtimashkov.wordpress.com

So I needed somehow to ask the browser to ignore this response header. Unfortunately Firefox doesn’t have any option for it. So I had either to use some intermediary proxy like WebScarab, or to use Fiddler 2 asking it to remove undesired header.

I used the last one. There is documentation how to remove header from response stream in Fiddler 2. It worked like a charm.

I did not take the time to determine whether google uses (on top of this) a js-based Framekiller (see the wikipedia link for proposition on how to override framekillers; I believe - without ever having tested it - that the greasemonkey addon for Firefox could also be useful in this context).

Speaks:  German English French Portuguese Russian Spanish       Collecting resources for: Mandarin Italian     Abandoned: Latin

Forum Timezone: America/New_York

Most Users Ever Online: wp_m8bqz1_sferrorlog

Currently Online: artichoke, Mompy25, shtnom3nitneulf
54 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Stephanie S: 742

Kevinpost: 499

Randybvain: 450

this_just_in: 328

Alasdair: 304

sipes23: 260

Member Stats:

Guest Posters: 9

Members: 62903

Moderators: 2

Admins: 5

Forum Stats:

Groups: 5

Forums: 16

Topics: 4915

Posts: 24860

Newest Members: robertcclark, shtnom3nitneulf, tanejvicky, VanDelfin, kingraj349, stokesy11

Moderators: Lingo: 664, anno: 205

Administrators: Benny: 485, balint: 0, tweaky: 0, AlexW: 0, The Duke: 0